Skip to content

Python dependency updates downgrade openai-agents #36

Open

Description

@abhishek-anand

openai-agents 0.24 requires websockets<17. requirements.in leaves both unpinned, so when an update bumps websockets to 17.3 (#33), the resolver drops openai-agents to 0.13.6 and openai from 3.45 to 2.54. The build still passes, so this is easy to miss.

Proposal: add openai-agents>=0.24 to requirements.in so updates can't go backwards. websockets then stays below 17 until openai-agents allows it.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions