Repository navigation
chore(deps): refresh lockfiles to patch 8 CVEs (root + examples/with-next) - #1238
Merged
Merged
Conversation
Contributor
|
@cursor can you fix commit messages so they pass the commitlint ci check |
Author
|
I reworded both PR commits so they pass the Angular commitlint preset —
Bodies, trailers ( |
Lockfile-only refresh of root deps whose declared ranges already allow the fixed upstream versions: - fast-uri 3.1.8 -> 3.1.9 * GHSA-w74x-v6f9-j3xg (moderate) URI scheme spoofing * GHSA-xhq7-xmqj-769h (low) path equivalence * GHSA-wjr9-j795-jxcr (moderate) host confusion * GHSA-333x-w4r6-6crp (low) scheme injection Via ajv@8.18.0 (range ^3.0.1). - ip-address 10.7.2 -> 10.7.5 * GHSA-rxp7-6hxx-x8q5 (moderate) ReDoS in Address6 zone matching Via socks@2.8.7 (range ^10.0.1). - serialize-javascript 7.0.5 -> 7.1.4 * GHSA-m5mm-p8h7-m29v (low) XSS via unescaped </script Via @rollup/plugin-terser (range ^7.0.3). - undici 6.29.0 -> 6.29.1 * GHSA-4qv8-2p9j-2685 (moderate) EventSource parser DoS * GHSA-xjj6-f33q-929c (high) excessive content-encoding DoS Via @actions/http-client (ranges ^6.23.0, ^6.25.0). No manifest or resolutions changes needed; achieved by deleting the affected lockfile blocks and running 'yarn install' so yarn re-resolves each range to the newest matching patch on the registry. Co-authored-by: Andreja Kogovsek <andrejak@users.noreply.github.com>
Patches the critical advisory GHSA-673q-mjm6-r5xr (unauthenticated RCE in 'use cache' functions returning typed arrays), which affects next >=16.0.0 <=16.4.0. The example's manifest range (^16.3.8) already allows 16.4.3, so this is a lockfile-only refresh (performed with yarn 1 to match the existing yarn.lock format). Co-authored-by: Andreja Kogovsek <andrejak@users.noreply.github.com>
cursor
Bot
force-pushed
the
cursor/dependabot-alerts-investigation-dece
branch
from
November 2, 2026 11:00
604ed9c to
6e3f6aa
Compare
andrejak
approved these changes
Nov 2, 2026
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.


Summary
Weekly Dependabot sweep. Fresh
yarn npm audit --recursive --allonorigin/mainsurfaced 7 CVEs across 4 root transitive deps whose declared ranges already permit the fixed upstream patch versions, plus a critical Next.js advisory inexamples/with-next/. All fixes are lockfile-only — no manifest edits, no newresolutionsentries.Root
yarn.lockfast-uri(viaajv@8.18.0)GHSA-w74x-v6f9-j3xg(moderate, URI scheme spoofing),GHSA-xhq7-xmqj-769h(low, path equivalence),GHSA-wjr9-j795-jxcr(moderate, host confusion),GHSA-333x-w4r6-6crp(low, scheme injection)ip-address(viasocks@2.8.7)GHSA-rxp7-6hxx-x8q5(moderate, ReDoS inAddress6zone matching)serialize-javascript(via@rollup/plugin-terser)GHSA-m5mm-p8h7-m29v(low, XSS via unescaped</script)undici(via@actions/http-client)GHSA-4qv8-2p9j-2685(moderate, EventSource parser DoS),GHSA-xjj6-f33q-929c(high, excessive content-encoding DoS)examples/with-next/yarn.locknextGHSA-673q-mjm6-r5xr(critical, unauthenticated RCE inuse cachefunctions returning typed arrays; affects>=16.0.0 <=16.4.0)Manifest range is
^16.3.8, so 16.4.3 is already allowed.How
Used the lockfile-refresh pattern: deleted the affected package blocks from each
yarn.lockand reranyarn installso yarn re-resolved each declared range to the newest matching patch on the registry. Theexamples/with-next/lockfile is a yarn 1 lockfile, so I ran yarn 1 in a scratch copy to preserve its format, then copied the resultingyarn.lockback. Noresolutionsentries added.Verification
yarn npm audit --recursive --all --jsonnow reports zero real CVEs (only pre-existing deprecation notices such aseslint 8.57.1 EOLremain, which are not security advisories).examples/with-next/: syntheticnpm audit(vianpm install --package-lock-only) reports0 vulnerabilities.Note on GitHub Dependabot alerts page
The GitHub App backing this automation does not have
vulnerability_alerts=read, so the Dependabot alerts page cannot be read programmatically. Independentyarn/npm auditoutput (above) is the signal used for this run — a maintainer may want to eyeball the alerts page to double-check parity.