This is similar to #458, however instead of checking with a user defined per-repo limit, we should check against the actual on disk conditions.
In this issue i propose we add a config value (maybe: facade_clone_reserve_space) to allow the user to configure an amount of space that should be kept free for facade clones.
The purpose of this reserve space is to prevent full-disk scenarios and/or full system lockups.
We already plan to check anticipated repo clone sizes in #459. In addition we should:
- query the filesystem that the configured facade clone path is on and measure its available space
- subtract the configured reserve space from that value
- check whether the remaining space is enough for the anticipated clone (assuming it passed the per-repo clone size check)
- raise an error and reject the clone/fail the whole task chain if there is insufficient space
This is similar to #458, however instead of checking with a user defined per-repo limit, we should check against the actual on disk conditions.
In this issue i propose we add a config value (maybe:
facade_clone_reserve_space) to allow the user to configure an amount of space that should be kept free for facade clones.The purpose of this reserve space is to prevent full-disk scenarios and/or full system lockups.
We already plan to check anticipated repo clone sizes in #459. In addition we should: