Repository navigation
Proposal: Upgrade CI to Java 17 #111
Copy link
Copy link
Open
Description
Proposal: Upgrade CI to Java 17
Problem
GitHub Actions CI builds are currently failing with the following error:
Required Java version 17 is not met by current version: 11.0.30
Root Cause
The quarkus-maven-plugin:3.6.9 (inherited from service-parent:5) requires Java 17 minimum:
<requiredJavaVersion>17</requiredJavaVersion>
<requiredMavenVersion>3.9.6</requiredMavenVersion>GitHub Actions runner environments were recently upgraded from Maven 3.8.x to Maven 3.9.6+. Maven 3.9.6+ strictly enforces plugin prerequisites, causing all PR builds to fail since March 16, 2026.
Timeline:
- Last successful PR build: December 12, 2025 (PR Update indy-model to version 2.2 #108)
- First failure: March 16, 2026 (PR Improve error messages in ErrorResponseExceptionMapper #110)
- Cause: GitHub Actions
ubuntu-latestrunner upgraded Maven to 3.9.6+
Proposal: Upgrade to Java 17
We should upgrade our CI environment and runtime to Java 17 for the following reasons:
- Quarkus 3.x officially requires Java 17+ - We're already using Quarkus 3.6.9
- Java 11 LTS support ends September 2026 - Only 6 months away
- Maven ecosystem moving forward - Maven 3.9.6+ enforces Java 17 for Quarkus plugins
- Aligns with industry standards - Java 17 is the current LTS baseline
Required Changes
CI Workflows
.github/workflows/pr-build.yml: Updatejava-version: '17'.github/workflows/merge-build.yml: Updatejava-version: 17
Runtime Environment
- Update Dockerfiles to use Java 17 base images
- Update Kubernetes/OpenShift deployment manifests
- Validate all dependent services are compatible with Java 17
Testing
- Run integration tests with Java 17
- Validate all services in the ecosystem
Impact
Currently blocked:
- PR Improve error messages in ErrorResponseExceptionMapper #110: "Improve error messages in ErrorResponseExceptionMapper"
- All new PRs will fail CI until this is resolved
Why local builds still work:
- Local Maven 3.8.8 doesn't strictly enforce plugin prerequisites
- CI uses Maven 3.9.6+ which enforces them
References
- Quarkus Maven Plugin: https://repo1.maven.org/maven2/io/quarkus/platform/quarkus-maven-plugin/3.6.9/
- Java 11 EOL Schedule: https://endoflife.date/java
- Maven Plugin Prerequisites: https://maven.apache.org/guides/plugin/guide-java-plugin-development.html
Reactions are currently unavailable
Metadata
Metadata
Assignees
Labels
No labels
Activity