diff --git a/actions/update_development_dependencies/requirements.txt b/actions/update_development_dependencies/requirements.txt index 16015350..6a25f1ee 100644 --- a/actions/update_development_dependencies/requirements.txt +++ b/actions/update_development_dependencies/requirements.txt @@ -45,7 +45,7 @@ platformdirs==4.12.4 poetry==2.5.1 poetry-core==2.5.0 poetry-plugin-export==1.10.1 -pre-commit==4.6.2 +pre-commit==4.7.0 pycparser==3.0 ; (platform_python_implementation != "PyPy" or sys_platform == "darwin") and implementation_name != "PyPy" and (sys_platform == "linux" or sys_platform == "darwin") pydantic==2.13.5 pydantic-core==2.46.5 diff --git a/pyproject.toml b/pyproject.toml index c900072c..c3affcb2 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -46,7 +46,7 @@ tomli-w = "1.2.0" [tool.poetry.group.actions-update_development_dependencies.dependencies] poetry-plugin-export = "1.10.1" -pre-commit = "4.6.2" +pre-commit = "4.7.0" pypi-simple = "1.8.0" toml-sort = "0.25.0" yamlfix = "1.19.1" @@ -57,7 +57,7 @@ poetry = "^2.3.1" poetry-audit-plugin = "^1.0.0" poetry-plugin-export = "^1.10.0" poetry-pre-commit-plugin = "^0.2.2" -pre-commit = "4.6.2" +pre-commit = "4.7.0" pylint = "4.1.3" pyright = {extras = ["nodejs"], version = "1.1.411"} safety = "~3.7.0" # TODO: Remove this version pin once the issue with safety is resolved