From 6d4a9f94ee25a12a4b7bd8fb27750f046fffe3f4 Mon Sep 17 00:00:00 2001 From: Irwin the IANA Bot Date: Tue, 20 Oct 2026 02:35:09 +0000 Subject: [PATCH 1/2] Update IANA special-purpose address registries --- iana/data/iana-ipv4-special-registry-1.csv | 51 +++++++++++---------- iana/data/iana-ipv6-special-registry-1.csv | 52 +++++++++++----------- 2 files changed, 50 insertions(+), 53 deletions(-) diff --git a/iana/data/iana-ipv4-special-registry-1.csv b/iana/data/iana-ipv4-special-registry-1.csv index 99458ca36cb..8d3c24a6bf7 100644 --- a/iana/data/iana-ipv4-special-registry-1.csv +++ b/iana/data/iana-ipv4-special-registry-1.csv @@ -1,27 +1,26 @@ Address Block,Name,RFC,Allocation Date,Termination Date,Source,Destination,Forwardable,Globally Reachable,Reserved-by-Protocol -0.0.0.0/8,"""This network""","[RFC791], Section 3.2",1981-09,N/A,True,False,False,False,True -0.0.0.0/32,"""This host on this network""","[RFC1122], Section 3.2.1.3",1981-09,N/A,True,False,False,False,True -10.0.0.0/8,Private-Use,[RFC1918],1996-02,N/A,True,True,True,False,False -100.64.0.0/10,Shared Address Space,[RFC6598],2012-04,N/A,True,True,True,False,False -127.0.0.0/8,Loopback,"[RFC1122], Section 3.2.1.3",1981-09,N/A,False [1],False [1],False [1],False [1],True -169.254.0.0/16,Link Local,[RFC3927],2005-05,N/A,True,True,False,False,True -172.16.0.0/12,Private-Use,[RFC1918],1996-02,N/A,True,True,True,False,False -192.0.0.0/24 [2],IETF Protocol Assignments,"[RFC6890], Section 2.1",2010-01,N/A,False,False,False,False,False -192.0.0.0/29,IPv4 Service Continuity Prefix,[RFC7335],2011-06,N/A,True,True,True,False,False -192.0.0.8/32,IPv4 dummy address,[RFC7600],2015-03,N/A,True,False,False,False,False -192.0.0.9/32,Port Control Protocol Anycast,[RFC7723],2015-10,N/A,True,True,True,True,False -192.0.0.10/32,Traversal Using Relays around NAT Anycast,[RFC8155],2017-02,N/A,True,True,True,True,False -"192.0.0.170/32, 192.0.0.171/32",NAT64/DNS64 Discovery,"[RFC8880][RFC7050], Section 2.2",2013-02,N/A,False,False,False,False,True -192.0.2.0/24,Documentation (TEST-NET-1),[RFC5737],2010-01,N/A,False,False,False,False,False -192.31.196.0/24,AS112-v4,[RFC7535],2014-12,N/A,True,True,True,True,False -192.52.193.0/24,AMT,[RFC7450],2014-12,N/A,True,True,True,True,False -192.88.99.0/24,Deprecated (6to4 Relay Anycast),[RFC7526],2001-06,2015-03,,,,, -192.88.99.2/32,6a44-relay anycast address,[RFC6751],2012-10,N/A,True,True,True,False,False -192.168.0.0/16,Private-Use,[RFC1918],1996-02,N/A,True,True,True,False,False -192.175.48.0/24,Direct Delegation AS112 Service,[RFC7534],1996-01,N/A,True,True,True,True,False -198.18.0.0/15,Benchmarking,[RFC2544],1999-03,N/A,True,True,True,False,False -198.51.100.0/24,Documentation (TEST-NET-2),[RFC5737],2010-01,N/A,False,False,False,False,False -203.0.113.0/24,Documentation (TEST-NET-3),[RFC5737],2010-01,N/A,False,False,False,False,False -240.0.0.0/4,Reserved,"[RFC1112], Section 4",1989-08,N/A,False,False,False,False,True -255.255.255.255/32,Limited Broadcast,"[RFC8190] - [RFC919], Section 7",1984-10,N/A,False,True,False,False,True +0.0.0.0/8,"""This network""","[RFC 791, Section 3.2]",1981-09,N/A,True,False,False,False,True +0.0.0.0/32,"""This host on this network""","[RFC 1122, Section 3.2.1.3]",1981-09,N/A,True,False,False,False,True +10.0.0.0/8,Private-Use,[RFC 1918],1996-02,N/A,True,True,True,False,False +100.64.0.0/10,Shared Address Space,[RFC 6598],2012-04,N/A,True,True,True,False,False +127.0.0.0/8,Loopback,"[RFC 1122, Section 3.2.1.3]",1981-09,N/A,False [1],False [1],False [1],False [1],True +169.254.0.0/16,Link Local,[RFC 3927],2005-05,N/A,True,True,False,False,True +172.16.0.0/12,Private-Use,[RFC 1918],1996-02,N/A,True,True,True,False,False +192.0.0.0/24 [2],IETF Protocol Assignments,"[RFC 6890, Section 2.1]",2010-01,N/A,False,False,False,False,False +192.0.0.0/29,IPv4 Service Continuity Prefix,[RFC 7335],2011-06,N/A,True,True,True,False,False +192.0.0.8/32,IPv4 dummy address,[RFC 7600],2015-03,N/A,True,False,False,False,False +192.0.0.9/32,Port Control Protocol Anycast,[RFC 7723],2015-10,N/A,True,True,True,True,False +192.0.0.10/32,Traversal Using Relays around NAT Anycast,[RFC 8155],2017-02,N/A,True,True,True,True,False +"192.0.0.170/32, 192.0.0.171/32",NAT64/DNS64 Discovery,"[RFC 8880]; [RFC 7050, Section 2.2]",2013-02,N/A,False,False,False,False,True +192.0.2.0/24,Documentation (TEST-NET-1),[RFC 5737],2010-01,N/A,False,False,False,False,False +192.31.196.0/24,AS112-v4,[RFC 7535],2014-12,N/A,True,True,True,True,False +192.52.193.0/24,AMT,[RFC 7450],2014-12,N/A,True,True,True,True,False +192.88.99.0/24,Deprecated (6to4 Relay Anycast),[RFC 7526],2001-06,2015-03,,,,, +192.88.99.2/32,6a44-relay anycast address,[RFC 6751],2012-10,N/A,True,True,True,False,False +192.168.0.0/16,Private-Use,[RFC 1918],1996-02,N/A,True,True,True,False,False +192.175.48.0/24,Direct Delegation AS112 Service,[RFC 7534],1996-01,N/A,True,True,True,True,False +198.18.0.0/15,Benchmarking,[RFC 2544],1999-03,N/A,True,True,True,False,False +198.51.100.0/24,Documentation (TEST-NET-2),[RFC 5737],2010-01,N/A,False,False,False,False,False +203.0.113.0/24,Documentation (TEST-NET-3),[RFC 5737],2010-01,N/A,False,False,False,False,False +240.0.0.0/4,Reserved,"[RFC 1112, Section 4]",1989-08,N/A,False,False,False,False,True +255.255.255.255/32,Limited Broadcast,"[RFC 8190]; [RFC 919, Section 7]",1984-10,N/A,False,True,False,False,True diff --git a/iana/data/iana-ipv6-special-registry-1.csv b/iana/data/iana-ipv6-special-registry-1.csv index f5bf9c073e8..82ff91d6ebb 100644 --- a/iana/data/iana-ipv6-special-registry-1.csv +++ b/iana/data/iana-ipv6-special-registry-1.csv @@ -1,28 +1,26 @@ Address Block,Name,RFC,Allocation Date,Termination Date,Source,Destination,Forwardable,Globally Reachable,Reserved-by-Protocol -::1/128,Loopback Address,[RFC4291],2006-02,N/A,False,False,False,False,True -::/128,Unspecified Address,[RFC4291],2006-02,N/A,True,False,False,False,True -::ffff:0:0/96,IPv4-mapped Address,[RFC4291],2006-02,N/A,False,False,False,False,True -64:ff9b::/96,IPv4-IPv6 Translat.,[RFC6052],2010-10,N/A,True,True,True,True,False -64:ff9b:1::/48,IPv4-IPv6 Translat.,[RFC8215],2017-06,N/A,True,True,True,False,False -100::/64,Discard-Only Address Block,[RFC6666],2012-06,N/A,True,True,True,False,False -100:0:0:1::/64,Dummy IPv6 Prefix,[RFC9780],2025-04,N/A,True,False,False,False,False -2001::/23,IETF Protocol Assignments,[RFC2928],2000-09,N/A,False [1],False [1],False [1],False [1],False -2001::/32,TEREDO,"[RFC4380] - [RFC8190]",2006-01,N/A,True,True,True,N/A [2],False -2001:1::1/128,Port Control Protocol Anycast,[RFC7723],2015-10,N/A,True,True,True,True,False -2001:1::2/128,Traversal Using Relays around NAT Anycast,[RFC8155],2017-02,N/A,True,True,True,True,False -2001:1::3/128,DNS-SD Service Registration Protocol Anycast,[RFC9665],2024-04,N/A,True,True,True,True,False -2001:2::/48,Benchmarking,[RFC5180][RFC Errata 1752],2008-04,N/A,True,True,True,False,False -2001:3::/32,AMT,[RFC7450],2014-12,N/A,True,True,True,True,False -2001:4:112::/48,AS112-v6,[RFC7535],2014-12,N/A,True,True,True,True,False -2001:10::/28,Deprecated (previously ORCHID),[RFC4843],2007-03,2014-03,,,,, -2001:20::/28,ORCHIDv2,[RFC7343],2014-07,N/A,True,True,True,True,False -2001:30::/28,Drone Remote ID Protocol Entity Tags (DETs) Prefix,[RFC9374],2022-12,N/A,True,True,True,True,False -2001:db8::/32,Documentation,[RFC3849],2004-07,N/A,False,False,False,False,False -2002::/16 [3],6to4,[RFC3056],2001-02,N/A,True,True,True,N/A [3],False -2620:4f:8000::/48,Direct Delegation AS112 Service,[RFC7534],2011-05,N/A,True,True,True,True,False -3fff::/20,Documentation,[RFC9637],2024-07,N/A,False,False,False,False,False -5f00::/16,Segment Routing (SRv6) SIDs,[RFC9602],2024-04,N/A,True,True,True,False,False -fc00::/7,Unique-Local,"[RFC4193] - [RFC8190]",2005-10,N/A,True,True,True,False [4],False -fe80::/10,Link-Local Unicast,[RFC4291],2006-02,N/A,True,True,False,False,True +::1/128,Loopback Address,[RFC 4291],2006-02,N/A,False,False,False,False,True +::/128,Unspecified Address,[RFC 4291],2006-02,N/A,True,False,False,False,True +::ffff:0:0/96,IPv4-mapped Address,[RFC 4291],2006-02,N/A,False,False,False,False,True +64:ff9b::/96,IPv4-IPv6 Translat.,[RFC 6052],2010-10,N/A,True,True,True,True,False +64:ff9b:1::/48,IPv4-IPv6 Translat.,[RFC 8215],2017-06,N/A,True,True,True,False,False +100::/64,Discard-Only Address Block,[RFC 6666],2012-06,N/A,True,True,True,False,False +100:0:0:1::/64,Dummy IPv6 Prefix,[RFC 9780],2025-04,N/A,True,False,False,False,False +2001::/23,IETF Protocol Assignments,[RFC 2928],2000-09,N/A,False [1],False [1],False [1],False [1],False +2001::/32,TEREDO,[RFC 4380]; [RFC 8190],2006-01,N/A,True,True,True,N/A [2],False +2001:1::1/128,Port Control Protocol Anycast,[RFC 7723],2015-10,N/A,True,True,True,True,False +2001:1::2/128,Traversal Using Relays around NAT Anycast,[RFC 8155],2017-02,N/A,True,True,True,True,False +2001:1::3/128,DNS-SD Service Registration Protocol Anycast,[RFC 9665],2024-04,N/A,True,True,True,True,False +2001:2::/48,Benchmarking,[RFC 5180]; [RFC Errata 1752],2008-04,N/A,True,True,True,False,False +2001:3::/32,AMT,[RFC 7450],2014-12,N/A,True,True,True,True,False +2001:4:112::/48,AS112-v6,[RFC 7535],2014-12,N/A,True,True,True,True,False +2001:10::/28,Deprecated (previously ORCHID),[RFC 4843],2007-03,2014-03,,,,, +2001:20::/28,ORCHIDv2,[RFC 7343],2014-07,N/A,True,True,True,True,False +2001:30::/28,Drone Remote ID Protocol Entity Tags (DETs) Prefix,[RFC 9374],2022-12,N/A,True,True,True,True,False +2001:db8::/32,Documentation,[RFC 3849],2004-07,N/A,False,False,False,False,False +2002::/16 [3],6to4,[RFC 3056],2001-02,N/A,True,True,True,N/A [3],False +2620:4f:8000::/48,Direct Delegation AS112 Service,[RFC 7534],2011-05,N/A,True,True,True,True,False +3fff::/20,Documentation,[RFC 9637],2024-07,N/A,False,False,False,False,False +5f00::/16,Segment Routing (SRv6) SIDs,[RFC 9602],2024-04,N/A,True,True,True,False,False +fc00::/7,Unique-Local,[RFC 4193]; [RFC 8190],2005-10,N/A,True,True,True,False [4],False +fe80::/10,Link-Local Unicast,[RFC 4291],2006-02,N/A,True,True,False,False,True From 68dc00bb57efc6d794832c7a8895a2bbddfbaf50 Mon Sep 17 00:00:00 2001 From: Kiel C Date: Tue, 20 Oct 2026 22:17:42 +0000 Subject: [PATCH 2/2] va: update test fixtures from IANA data refresh. --- va/http_test.go | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/va/http_test.go b/va/http_test.go index dd925cb46e5..d5750bbb50a 100644 --- a/va/http_test.go +++ b/va/http_test.go @@ -370,7 +370,7 @@ func TestNewValidationRecordFromRedirect(t *testing.T) { Name: "bare IPv4, reserved IP address", Location: "http://10.10.10.10", ExpectedError: "invalid host: " + - "IP address is in a reserved address block: [RFC1918]: Private-Use", + "IP address is in a reserved address block: [RFC 1918]: Private-Use", }, { Name: "bare IPv6, implicit port", @@ -399,7 +399,7 @@ func TestNewValidationRecordFromRedirect(t *testing.T) { Name: "bare IPv6, reserved IP address", Location: "http://[3fff:aaa:aaaa:aaaa:abad:0ff1:cec0:ffee]", ExpectedError: "invalid host: " + - "IP address is in a reserved address block: [RFC9637]: Documentation", + "IP address is in a reserved address block: [RFC 9637]: Documentation", }, { Name: "bare IPv6, scope zone",